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Introduction
This chapter covers the following topics:

l Overview (page 6)
l Installing the BD CellView™ Lens plugin (page 8)



Overview
The BD CellView™ Lens plugin for FlowJo™ v10 provides the complete set of tools that allows you to visually
explore all the image data captured and then exported from the BD FACSDiscover™ S8 cell sorter. After the
FCS and imaging data are exported from BD FACSChorus™, use the BD CellView™ Image Extractor to
convert the exported image event data from Chorwave format (CVW) to TIFF (Tagged Image File Format).
Further analysis of the extracted imaging data (TIFF) is performed by using the plugin. You can also use
imaging data in other formats (jpg and png) from other cytometers or data sources to analyze them by
using the plugin.

To know more about exporting data from BD FACSChorus™, see the Exporting and deleting data section in
BD FACSDiscover™ S8 Cell Sorter with BD CellView™ Image Technology User's Guide.

To know more about BD CellView™ Image Extractor, see the Extracting images section in
BD FACSDiscover™ S8 Cell Sorter with BD CellView™ Image Technology User's Guide.

With the BD CellView™ Lens plugin for FlowJo™ v10, you can:

l Use the interactive Images Browser to display customized views of cell images for specific populations
and also connect to FlowJo™ software's graph window to allow mouse-over image display. Images can be
sorted by any sample parameter and snapshots taken and displayed in FlowJo™ software's layout editor
automatically.

l Use the Image Filters tool to enhance the image for any single channel image by adding a sequence of
filters, such as color, smoothing, and thresholds, and additionally compose an overlay channel that
combines multiple channels into a single image.

To start using the BD CellView™ Lens plugin, first, load your FCS sample file into a FlowJo™ workspace by
using FCS_With_Images_Loader, a workplace plugin, and then create sub-populations using gating or
clustering tools, if necessary. After selecting a population, save the file and then choose the BD CellView™
Lens plugin from the Workspace –Plugins menu to create a plugin node for that population. You can add a
plugin node to another population using the Workspace –Plugins menu or by dragging an existing plugin
node to the population.
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Best practices

For optimal performance of the BD CellView™ Lens plugin, we recommend:

l Running the plugin with the FCS and image files on a local drive rather than an external one.

l Storing the FCS, index sort CSV, and image files in the same mapped folder.

The recommended hierarchy of files and sub-folders containing extracted TIFF images within a
successfully mapped parent folder is shown in the following images.

Recommxended folder structure for a non-index sort experiment.

Note: Make sure that a non-index sort experiment mapped folder contains the extracted images folder
and an FCS file.

Recommended folder structure for an index sort experiment.

Note: Make sure that an index sort experiment mapped folder contains a CSV file along with the
extracted images folder and FCS file.
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Installing the BD CellView™ Lens plugin
To install BD CellView™ Lens plugin on your workstation:

Note: The following procedure works for Mac® and Windows® workstations.

1. Go to https://www.flowjo.com/exchange/#/ and search for the plugin.

2. Download the BD CellView™ Lens plugin.jar file on to your local workstation.

3. Copy the plugin.jar (BD_CellView_v1.0.jar) file to the FlowJo™ plugins folder in your workstation.

Note: If you start FlowJo™ software after performing step 3, you do not have to perform the following
steps. You can start using the plugin by mapping the image files to events. See Mapping the image files
to events (page 12).

Note: If you have started FlowJo™ software, perform the following steps to continue installing the
plugin.

4. Open FlowJo™ software and go to FlowJo > Preferences > Diagnostics.

In the FlowJo: Diagnostics window, click to select the Scan for plugins option, then click Choose, and
then select the location of the plugins folder.

5. Click OK.
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6. Restart FlowJo™.

The BD CellView™ Lens plugin is available for you to use underWorkspace > Pluginsmenu as
BD_CellView_Lens.

You can start using the plugin by mapping the image files to events. See Mapping the image files to
events (page 12).
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Using the BD CellView™ Lens plugin
This chapter covers the following topics:

l Mapping the image files to events (page 12)
l Using the images browser (page 23)
l Using the Image Filters tool (page 33)
l Using the Index Sort Plate Viewer (page 31)
l Using the Event to image plot functionality (page 45)
l Using the Snapshot to layout functionality (page 47)



Mapping the image files to events
When the first plugin node is created for a sample’s population, the new plugin node must determine the
root folder where image files are located and be able to map an event number to an image file name. When
first created, the plugin node will attempt to find the image folder and file name mapping based on the
location of the FCS file. Typically the image files are organized into numerical subfolders (e.g. ‘00000000’,
‘00010000’, etc) where 10,000 images files are located in each subfolder.

To generate the folders containing the images, you must first convert the exported image event
data that was recorded in Chorwave format (CVW) to TIFF (Tagged Image File Format) by using
the BD CellView™ Image Extractor. To know more about BD CellView™ Image Extractor, see the
Extracting images section in BD FACSDiscover™ S8 Cell Sorter with BD CellView™ Image
Technology User's Guide.

Note: If your images are organized such that all image files are located in a single folder, make sure the Use
numerical subfolders checkbox is not selected.

Note: The plugin nodes must be created under the root sample population for the mapping to be successful.

After mapping the image files to events, you can either confirm or change the root folder of image files and
the name mapping information. If the file name prefix, suffix, and event number length are correct, the
plugin displays a confirmation that an image file is correctly found. If not, you can enter the prefix and
suffix values manually until the image file name is confirmed.

You can also perform the mapping procedure by navigating to the images browser menu bar and by clicking
Tools > Open Event To Image File Mapping Dialog. See Mapping the image files to events using the
images browser menu (page 19).

12 BD CellView™ Lens Plugin for FlowJo™ v10 Software User's Guide



Mapping the image files to events using a workspace plugin

Procedure
To map the image files to events using a workspace plugin:

1. Start FlowJo™.

A workspace displays by default.

2. Save the workspace.

3. Go to Plugins > Add Workspace Plugin.

The workspace plugin allows you to load the FCS files that contain the images you want to analyze with
BD CellView™ Lens plugin.

The Add FlowJo Workspace Plugins dialog displays.

4. From the drop-down menu in the Add FlowJo Workspace Plugins dialog, select the
FCS_With_Images_Loader workplace plugin.
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5. Click OK and click Save.

The Choose folder to start loading FCS files dialog displays.

6. Browse the workstation to select the folder where the FCS files are located.

7. Click Open.

An "Adding sample(s)" progress bar at the bottom of FlowJo™ displays the FCS files being loaded.
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After the progress bar reaches 100%, it closes and the workspace displays all the FCS files that were
successfully loaded on to FlowJo™.
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8. Click to select an FCS file.

The FCS file opens in an ungated window.

Note: Regardless of the adjustements for axes or scaling or both that you may have performed in
BD FACSChorus™ while recording the FCS data, to view the events properly in FlowJo™, you may have to
readjust the axes or scaling or both.
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9. Gate on the cells of your interest from the selected FCS data sample.

Note: Creating gates can also help you identify singlets and eliminate doublets from the selected FCS
data sample. While creating gates, you may also have to readjust the axes or scaling or both while
creating gates.
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10. To view the images in your gated population of interest, click to select the population of interest in the
workspace and then go toWorkspace menu > Plugins > BD_CellView_Lens.

A new node with a camera lens icon displays below the node for which you want to view the images.

Immediately after, the BD CellView™ Lens plugin opens with the Images Browser displaying a wall of
images. See Using the images browser (page 23).
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Mapping the image files to events using the images browser menu

The first time you create a BD CellView™ Lens plugin node for a sample file, you will be automatically
prompted to map the image files to events.

Procedure
To map the image files to events using the images browser menu:

1. In the Images browser menu bar, go to Tools > Open Event To Image File Mapping Dialog.

The Event Number to File Mapping dialog displays.

2. For non-index sort experiments, select or clear the User numerical subfolders checkbox depending on
how the image files were extracted.

Note: If your images are organized after extraction such that all image files are located in a single
folder, make sure the Use numerical subfolders checkbox is not selected.

For index sort experiments, you must clear the User numerical subfolders checkbox if it is selected.
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3. Do one of the following:

a. If you want to analyze the data for a non-index sort experiment, click Set Folder and go to step 4.

b. If you want to analyze the data for an index sort experiment, click Use Index Sort File and go to
step 5.

Note: Make sure that the User numerical subfolders checkbox is not selected.

Note: For the Use Index Sort File button to display in the Event Number to File Mapping dialog, the
plugin node must be created under the root sample population.
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c. If you want to analyze images from the BD® Research Cloud, click the BD Logo icon, select the
images and go to step 6.

4. Browse the workstation to select the root folder where the extracted TIFF image files are located.

If your images are organized such that all image files are located in a single folder, make sure the Use
numerical subfolders checkbox is not selected.

5. [Optional] To analyze the data for an index sort experiment, you must select the index sort CSV file and
click Open.

The folder containing the index sort data is mapped now.

Note: To ensure successful mapping of the data for an index sort experiment, make sure that the plugin
node is created under the root sample population.

6. Click OK.
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The BD CellView™ Lens plugin opens with the Images Browser displaying a wall of images. See Using the
images browser (page 23).

After mapping the image files to events, you can either confirm or change the root folder of image files
and the name mapping information. If the file name prefix, suffix, and event number length are correct,
the plugin displays a confirmation that an image file is correctly found. If not, you can enter the prefix
and suffix values manually until the image file name is confirmed.
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Using the images browser
Once the file name mapping is successful, the Images Browser opens to display a wall of images (with a
default of ten rows and five columns), with one of the single cell images highlighted in the high resolution
display panel. This panel shows the raw image in a higher resolution using linear interpolation of the pixels,
as well as the image for each channel of the image data. You can click on an image in the image wall to
change the highlighted single channel cell image, or click on one of the channels, of the particular image,
located below the high resolution display panel, to show that channel in the higher resolution display.

Images Browser user interface

No. Interface component What you can do

1 Image wall Displays FCS event images in wall view.

The default view consists of ten rows and five columns.

2 High resolution display panel Displays the raw image of a selected single image from
the image wall in a higher resolution using linear
interpolation of the pixels.

3 Channels of selected image Displays the selected single image in a number of
channels.

The number of channels displayed depend on the number
of image fluorescence channels you had selected for your
experiment in BD FACSChorus™ and are interpreted from
the extracted TIFF image files.
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No. Interface component What you can do

4 Image display controls Displays the controls to customize the display of images
in the images browser.

Allows you to view the extracted images for an index sort
experiment by using the Index Sort Image Viewer
window.

For more information, see Image display controls user
interface (page 28).
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Images browser menu bar

The images browser includes a menu that allows you to perform certain key functions.

Note: Depending on your workstation's Operating System (Mac® or Windows®), the location of the menu
bar will vary. For a Mac® system, the menu bar displays at the top-left corner of your screen detached from
the images browser. For Windows®, it displays attached to the images browser and at the top-left corner of
the images browser window.

The images browser menu bar consists of the following tabs:

No. Menu bar component What you can do

1 View

Allows you to change the display of the images browser. Keyboard shortcuts
are provided as well.

Note: The keyboard shortcuts vary depending on your workstation's

Operating System.

See Image display controls user interface (page 28).
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No. Menu bar component What you can do

2 Tools

Allows you to access the following tools and the corresponding shortcuts:

l Snapshot to Layout. See Using the Snapshot to layout functionality (page
47).

l Make Image Files Gate - Allows you to create two subpopulations: one for
events with image files, one for events that have no image files.

Note: The feature is only available when the plugin node is created on the
root sample population.

l Run Slideshow - Allows you to view through each image in an all open
images browser. Click once to start the slideshow. Click it again for the
slideshow to stop.

l Concatenate Samples with Images - Allows you to create a new FCS file
that is a concatenation of all sample files that also have a BD CellView™
Lens plugin plugin node somewhere in its gating hierarchy. The new FCS
file will include all parameters for every file, and will remember how to map
its image files to event numbers.

l Image filter tool - See Image filters tool preview (page 42).

l Index Sort Plate Viewer - See Using the Index Sort Plate Viewer (page 31).

l Event to image file mapping dialog - See Mapping the image files to
events (page 12).

l Event to image plot (Open 2D Plot with MouseOver) - See Using the Event
to image plot functionality (page 45).

Note: The keyboard shortcuts vary depending on your workstation's

Operating System.
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No. Menu bar component What you can do

3 Prefs

Allows you to change the default behavior of the images browser as follows:

l Show Missing Image Files Warning – If selected, a warning message
displays in the image wall if there are enough missing image files that the
wall could not be filled

l Show Placeholders for Missing Image Files – If selected, a blank rectangle
is drawn for each image file that is missing (rather than skipping the file)

l Show BD Research Cloud GUI – If selected, display the BD® Research
Cloud icon in the Images Browser to upload the image files for the current
population, and display the same icon in the Event to Image File Mapping
dialog to download image files from BD® Research Cloud. See Image
display controls user interface (page 28).
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Image display controls user interface

No. Interface component Description

1 Allows you to add or remove rows and columns to
the image wall.

2 Allows you to switch between all channels view in
the image wall or the image wall view (selected by
default).

Channels view

Wall view (default view)
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No. Interface component Description

3 Allows you to access the following tools:

1. Image filters – Allows you to add image
processing filters for each channel of the
image data. For more information, see Using
the Image Filters tool (page 33).

2. Event to image plot – Allows you to open a
FlowJo™ graph window to enable mouse-over
and cell location capabilities. For more
information, see Using the Event to image plot
functionality (page 45).

3. Snapshot to Layout – Allows you to update
FlowJo's layout editor with a snapshot image
of the current view of the images browser for
reports and publication. For more information,
see Using the Snapshot to layout functionality
(page 47).

4. BD® Research Cloud – Allows you to upload all
the image files for the currently viewed
population to the BD® Research Cloud server.
Upon clicking the icon, follow the prompts for
the location (organization and project or
workflow) to upload the files.

5. Index Sort Plate Viewer – Allows you to open
the index sort plate viewer dialog (that opens
on top of the images browser) to view the
extracted images for an index sort experiment
in the images browser. For more information,
see Using the Index Sort Plate Viewer (page
31).

4 By using the functions listed below, you can:

l Show Event Numbers – Show the event
numbers for each image on the image wall
(selected by default).

l Center Images – Center the images on the
image wall.

l Autofit Image – Fit the high resolution image
display to the size of the main window (selected
by default).

l Show Main Image Channels – Show or hide the
channels of the selected image in the high
resolution interpolated display, and if selected,
set its size to either 2x (selected by default) or
1x.
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No. Interface component Description

5 By using the functions listed below, you can:

l Prev/Next – Move to next or previous page of
images in the image wall.

l Sort Ascending – Sort images in ascending
order of event numbers (selected by default).

l Drop-down menu – Sort images based on
specific sample parameters such as
Event # (default option) and other comparable
parameters depending on the experiment.

l Random images – Display images in a random
order.

6 Allows you to close all open image browsers
simultaneously.
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Using the Index Sort Plate Viewer
For analyzing index sort experiment data, use the Index Sort Plate Viewer to display a wall of images on the
images browser with one of the single cell images highlighted in the high resolution display panel.

The Index Sort Plate Viewer allows you to control the set of images displayed in the image browser by
selecting individual wells of the plate, or by selecting sorted populations defined by the wells.

You can click on a single well to display all the images for that particular well, or you can click on a
Population name to display the images for events in that population.

To view the Index Sort Plate Viewer:

1. From the image controls display panel, click the Index Sort Plate Viewer icon.

The Index Sort Plate Viewer dialog displays on top of the images browser.

After opening the Index Sort Plate Viewer dialog, a wall of images display on the images browser.
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The number of images on display depends on the number of cells index sorted into that well.

2. Click on a single well to display all the images for that particular well, or you can click on a Population
name to display the images for events in that population.
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Using the Image Filters tool
The image filters tool allows you to refine the display of images in each channel by adding different color
options, image processing filters, and by controlling the composition of the Overlay channel.

To open the image filters tool, click the Image Filters tool button in the images browser display controls
panel. The image filters tool displays as a separate window.

You can also open the image filters tool by double-clicking an image on the image wall or by navigating to
the images browser menu bar and by clicking Tools > Open Image Filter Tool. See Images browser menu
bar (page 25).

When the first BD_CellView_Lens node is created, the plugin automatically creates a filters set named
‘Auto-Color Smoothed’ to use as the default custom filters set. The filter set that displays with the Image
Filter tool window is set to Default. Under this setting, the filters for each imaging channel has been set to:
0, lowest position, highest position, 1, and 50% for Smoothing, Minimum. Maximum, Gamma, and Overlay
Opacity, respectively. See Image filters tool user interface (page 34).

Under this setting, the filters for each imaging channel has been set to: 0, lowest position, highest position,
and 1 for Smoothing, Minimum. Maximum, and Gamma, respectively. The Overlay Opacity is set to: 100%,
60%, 50%, 40%, 30%, 20% for the imaging channels: LightLoss, FSC, SSC, Imaging BP/534..., Imaging
BP/598..., Imaging BP/788..., respectively. See Image filters tool user interface (page 34).
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Image filters tool user interface

Note: Hovering over different sections of the Image Filter tool window displays a tool tip with a description
for the feature.
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No. Interface component What you can do

1 Channel adjustments Allows you to adjust the following channel filters
by using the respective slider bars:

l Smoothing
l Minimum (Min)
l Maximum (Max)
l Gamma

Also allows you add or remove the following
filters by selecting or clearing the corresponding
checkboxes:

l Invert
l Sharpen
l Edges

For the selected channel, the image filter tool
displays a histogram showing the distribution of
pixel values in an image for that channel.

The histogram is updated as you adjust the
sliders and the filters above.

You can also undo and redo all channel
adjustments by using the respective icons.

2 Image panel For the selected channel, a high resolution
interpolated image of a cell event image
representing the selected channel (or the overlay
channel) displays.

The high resolution image is is updated as you
adjust the sliders and the filters in the channel
adjustments panel.

Click the Show Overlay checkbox to apply the
overlay channel while adjusting the current
channel.

Note: The Show Overlay checkbox is not selected

by default.

3 Undo-redo buttons Allows you to undo or redo the last action you
performed on the image filters window.
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No. Interface component What you can do

4 Image filters panel - Select image filters l Select or clear the different channels
l Set channel colors
l Change the order of the channels
l Save filter sets
l Set the text color to white
l Reset all selections
l Remove channels from view (by using Delete

channels button)
l Specify channel overlay types
l Apply current filters to all image browsers

across the workspace

For more information, see Image filters tool -
selecting filters user interface (page 37).

5 Image filters panel - Channel images l Use the positive and negative magnifying
glass icons to increase or decrease the size of
the cell event images.

l Select the MouseOver Scale check box, the
size that the image is adjusted to here will
also be displayed in the 2D plot window that
opens from the Event to plot button in the
Images Browser.

l View individual cell event images across all
channels

For more information, see Image filters tool -
channel images user interface (page 39).
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Image filters tool - selecting filters user interface

No. What you can do

1 Select one or more checkboxes to view the particular channels in the
Image filters tool - channel view.

Clear one or more checkboxes if you do not want to view the particular channels in the
Image filters tool - channel view.

2 Select the colors for the channels.

To remove the color for a channel (set no color), hold the shift key while clicking on the
color button.

3 Select a saved filter set from the Filters Sets drop-down menu.

4 Save the current filter set to a file.

5 Load a saved filter set from a file.
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No. What you can do

6 Use the arrows to move the channels up or down to determine the order of the
channels.

Note: Modifying the order of the channels is only possible with Transparent or Solid

Overlays.

7 Enter the name for the channels or edit them.

8 Select the Overlay settings for the channels. The available options are:

l Blended Overlay (selected by default)
l Transparent Overlay
l Solid Overlay

See Using Overlays (page 39).

9 Save the current filter set with a distinct name.

10 If you have selected to show the event number for images in the image browser tool,
you can set the text color to display as white.

By default, the checkbox is not selected and the text color is set to black.

11 Apply the current filter settings to all image browsers.

12 Remove filters settings and all other selections for all channels.

13 Allows you to delete the current filters set from the list of filters.

Upon deleting a filters set, the deleted filters set does not display in the drop-down list
of available saved filters sets (3).
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Image filters tool - channel images user interface

No. What you can do

1 Increase or decrease the image size.

2 Use current image size for mouse-over in plots.

3 The red border indicates the selected channel that is displayed in the Image filters -
channel view.

4 The order of channels as determined by the order in which they are set up in the Select
image filters panel on the right side.

Using Overlays

In addition to the individual images for each channel, the BD CellView™ Lens plugin creates an additional
Overlay channel that combines the enabled channel images to make a single channel image. The images
are overlaid in the order shown in the channel list, which can be rearranged using the up and down arrow
buttons located next to the channel names.

Chapter 2.  Using the BD CellView™ Lens plugin 39



To visualize the overlays before implementing the overlay settings, you can use the image filters tool
preview feature. See Image filters tool preview (page 42).

When composing the Overlay channel, you can choose the following options for how the layers are
constructed:

Overlay What you can do

Blended If using blended overlays, the color of an individual pixel in an image is determined by adding the
color of that pixel from each enabled channel. For example, if the color for the pixel in channel 1 is
red and the color in channel 2 is green, the resulting pixel is colored yellow.

Note: The order of the channels does not affect the final pixel color.

A blended overlay implements a technique called 'additive blending', where each pixel in the overlay
is constructed by adding the weighted pixel RBG values for each channel color. The order of the
channels will not affect the final overlay image.
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Overlay What you can do

Transparent A transparent overlay is constructed by stacking the channel images on top of each other, where the
amount shown for a specific channel is determined by its opacity setting, between 0 and 100%.

If using transparent layers, you can set the opacity for each channel using the slider bar. You should
adjust the opacity for each channel as it is overlaid, so that each channel shows through in the
Overlay channel. For each channel as the opacity number is decreased or increased, the opacity
increases or decreases, and less and more of the other channels will be seen through the current
channel in the overlay, respectively. To help ensure that each layer is displayed and not blocked by a
following layer, it is recommended that the first layer is set to 100%, and subsequent layers set 70%
or lower, and a layer’s opacity is not greater than the one before (for example: 100%, 70%, 50%, 30%,
etc.)

Solid Use the slider bar to set the Pixel Overlay Threshold to determine whether a pixel from the channel
image is included in the overlay image or not. The intensity of each pixel in the image is normalized
to a percentage of the intensity range, and is compared to the threshold value.

For example, you can specify that the top %50 brightest pixels for Channel X are used when
constructing the Overlay.
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Image filters tool preview

To help visualize the different types of overlays and how they are composed, the Image Filters Tool can be
opened to display a preview of artificial channel images composed of overlapping rectangles for each
channel.

To open the image filters preview tool, press the [Shift] key and double-click on an image in the image wall.

Using the image filters preview tool, you can select or clear channels and set their colors to illustrate how
pixel colors are blended, how transparent layers are overlaid, or how solid layers are composed.

The following images are examples of the image filters preview tool with a single channel with the same
color selections and with differing overlay variations:

Saving filters sets

Once you have added the image filters and composed the Overlay channel, you can save these settings with
a name as a filters set to your workspace by clicking on the Save Filters button. You can overwrite existing
filters sets, or create a new filters set by adjusting the channel and filter settings and entering a new name.

Restoring filters sets

To restore the tool to a previously saved filters set, choose an existing filters set from the drop-down menu.
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Resetting filters sets

If you want to start by creating a new filter set, use the Reset button to remove all filters and colors from all
channels.

Note:When the first BD_CellView_Lens node is created for a sample with image files, the plugin will
automatically create a filters set named ‘Auto-Color Smoothed’ to use as a starting point for your custom
Filters Set.

Image filters menu bar

The image filters window includes a menu that allows you to perform perform certain key functions.

Note: Depending on your workstation's Operating System (Mac® or Windows®), the location of the menu
bar will vary. For a Mac® system, the menu bar displays at the top-left corner of your screen detached from
the images browser. For Windows®, it displays attached to the images browser and at the top-left corner of
the images browser window.

The images browser menu bar consists of the following items:

No. Menu bar component What you can do

1 Edit

Allows you to undo or redo the last action you performed on the image filters
window.

The exact name of the last actions you performed is displayed next to Undo
and Redo depending on the order in which you performed them.

2 View

Allows you to:

l Increase or decrease the image size by clicking the buttons or by clicking
the corresponding shortcut keys (+ or -).

l Hide the disabled (not selected) channels
l Set the mouse-over scale for the plots
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No. Menu bar component What you can do

3 Operations

Allows you to:

l Load filter sets from file
l Save filter sets to file
l Save filter sets with name
l Reset filters to default
l Set text color to white (selected by default)
l Use solid overlays
l Apply filter sets
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Using the Event to image plot functionality
While viewing the images for a cell population in the images browser, you can open a FlowJo™ graph
window for that population to show a 2 dimensional (2D) plot, where individual cell images are displayed as
you move the mouse over the dots in the graph area.

Note: For an index sort experiment, only index sort cell images are displayed.

Click the Event to image plot button to use a graph window that is already open for the population
selected in FlowJo™. If a graph window is not already open, a new graph window opens.

You can also use this feature by navigating to the images browser menu bar and by clicking Tools > Open
2D Plot with MouseOver. See Images browser menu bar (page 25).

As the plugin retrieves information for the image plot, graph window displays a yellow border.
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On moving the mouse into the graph area, the border turns green indicating the mouse-over feature is
working.

You can change the x or y axis parameters and the plugin updates to continue with the mouse-over feature.

In the image above, note that only one image is shown, although there may be many cells at that location
in the plot. In addition to showing a cell image using your mouse, you can also show the location of any cell
that is displayed in the image wall of the Images Browser by clicking on the image in the image wall.
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Using the Snapshot to layout functionality
If you want to take pictures of the cell images that are displaying in the Images Browser for use in a report
for publication, you can use the Snapshot to layout button in the Image display control panel.

Click the Snapshot to layout button to capture the cell images that are visible in the Wall View or Channels
View, and automatically places them in FlowJo™'s layout editor.

You can also use this feature by navigating to the images browser menu bar and by clicking Tools > Take
Snapshot for Layout Editor. See Images browser menu bar (page 25).

The plugin will create a new layout with the population's name or use an existing layout with that name.
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If you want to capture larger images from the image wall (consisting of multiple images), select an image
on the image wall and then press the [Shift] key while clicking the Snapshot to layout button to include the
other images on the image wall as necessary.
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3
3.

Troubleshooting
This chapter covers the following topic:

l Troubleshooting the BD CellView™ Lens plugin (page 50)



Troubleshooting the BD CellView™ Lens plugin
Observation Possible cause Recommended solution

Images are not loading for index
sort file.

The Use numerical subfolders
checkbox is checked, but the
image files are stored in one
folder

Check the folder structure where the image
files are stored and select the 'Use numerical
subfolders' checkbox accordingly

The index sort CSV file, FCS data
file, and images folder are not
found together in the same
parent folder

Move or copy the index sort CSV file, FCS
data file, and images folder so that they are
all contained in the same folder, ideally with
no other files or folders

Image file names contain
characters that corrupt the file
path

Check the names of the image files for the '/'
(slash) character. If found rename or re-
export the files to omit the '/' (slash)
character

Images folder is incorrect Confirm if the images folder is correct and if
necessary, change the folder by clicking 'Set
Folder' in the Event Number to File Name
Mapping dialog

The user does not have read
permission for the image files

Confirm if all the image files have the correct
permissions to be accessed by the user and
the application.

The index sort CSV file has
incorrect format or is missing
information

Inspect the index sort CSV file and confirm it
contains columns for 'Well', 'Event', 'Sort
Population', 'EventIndex'

Background is observed on
overlay images which is not
present on individual channels
images.

One or more channels contains
'noisy' pixel values that vary over
the entire image

Use the Image Filters Tool to inspect
individual channels for noisy data, determine
if channel can be disabled.

Adjust the Gamma filter value for channels
with noisy data.

Use the Transparent or Solid Overlay options.
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